MAINTENANCE

You have reached the Sigma Touch maintenance page, the information below is specifically for the maintenance of the Sigma Touch. 

LIVE TECHNICAL FEED

Touch Screen Issue
A number of faults have been reported about the touch sensitivity of the screen. After thorough testing we have found this to be due to the fact that when the screen is being cleaned they are spraying the cleaning solution directly onto the screen, which causes liquid to drip down inside the machine and in turn effects the functionality.
PLEASE ONLY CLEAN THE SCREEN BY SPRAYING THE SOLUTION ON THE CLOTH.
See Question 1 of the ‘How do I?’ section below for more info.

HOW DO I...

You will need:

Screen Cleaner - 1015014
Microfibre Cloth - 1015012

  1. Unplug the Molex Connector
  2. Undo the 6 x 7mm Nuts
  3. Lift off the Screen
  4. Spray Screen Cleaner onto the Micro Fibre Cloth (Do not spray directly onto the screen)
  5. Clean the screen

       

        6. Replace the screen

         7. Redo the 6 x 7mm nuts

         (DO NOT OVER TIGHTEN)

         8. Reconnect the Molex connector

1. Clean sensor lense

2. Check to see if GREEN LED is on

3. Turn Screw clockwise till AMBER LED is on

4. Turn anti-clockwise 1/4 back

5. Test cup dropper in 'operator functions' to check calibration

1. Open the door

2. 'Operator Functions'

3. Test Cup Dropper

4. Cup carousel will time out after 30 seconds

DOCUMENT - HOW TO LOAD THE CUP UNIT

To add custom branding to the screen you will need to use the Sigma Touch Custom Branding Pack which can be downloaded HERE

To diagnose and error code please refer to our Quick Reference Guide which you can download HERE

Sigma FAQs

14 Simply means a circuit error. The number following is the actual error. In this case '7' means Faulty Valve 2. 

Refer to Triac circuit information

Reason: 

Faulty Valve 2 

 

Solution:

Replace Valve and re-calibrate 6fl oz or 170 grams

Test:

Test valve 2 in flush mode

Solution:

Reload CONFIG file

  • Service Mode
  • Machine Settings
  • Load/Read/Config
  • Load into machine
  • or Read from machine

Refer to Service menu image

Test:

Test All Drink Selections

14 Simply means a circuit error. The number following is the actual error. In this case '20' means Whipper Station 1 issue. 

Refer to Triac circuit information

Reason: 

Whipper Station 1 Issue

Possible Cause/Solution: 

Cause 1 : 

Whipper Seals leaking

Solution 1 :

Check all seals - replace whipper seals if needed 

Cause 2 : 

Fuse F11 

Solution 2 :

Check Fuse F11 - replace if needed (Part #)

Cause 3 : 

Whipper Motor Issue

Solution 3 :

Check Check Whipper Motor - replace if needed 

Preliminary Check: 

Check that 'Carousel Time out' is set to 30 seconds. 

  • Machine settings
  • Cup settings
  • Carousel timeout/30 seconds

Possible Cause/Solution: 

Cause 1 : 

Cups are jammed/loaded incorrectly/damaged

Solution 1 : 

Reload cups - Refer to HOW TO LOAD THE CUP UNIT

Cause 2 : 

Fuse F9 Issue

Solution 2 : 

Check F9 T2.0 Amp fuse and replace if needed 

  • Power off machine
  • Remove all cups
  • Check F9 Fuse
  • Power on machine

Cause 3 : 

Cup Carousel Motor Issue

Solution 3 : 

Does Cup carousel turn under load?

Yes - HOW TO LOAD THE CUP UNIT

No - Replace cup carousel Motor 

Test : 

Possible Cause/Solution: 

Cause 1 : 

Cups are jammed/loaded incorrectly/damaged

Solution 1 : 

Reload cups - Refer to HOW TO LOAD THE CUP UNIT

Cause 2 : 

Fuse F9 Issue

Solution 2 : 

Check F9 T2.0 Amp fuse and replace if needed 

  • Power off machine
  • Remove all cups
  • Check F9 Fuse
  • Power on machine

Cause 3 : 

Operation of Cup Scrolls

Solution 3 : 

Reload a few cups - NOT into one position

Test :