Welcome to the new Service Guide

Fault Finding

Use this section for error codes, fault finding, cleaning and recommended parts.

2021-12-10_11h38_40
Sigma High Pressure Brewer Codes
Westomatic Vending Services Sigma Error Codes
General Sigma Error Codes
Sigma 12 Month Check Up HPB LPB
HPB & LPB 12 Month Check Up
2021-12-14_14h04_40
Freshbrew and Instant 12 Month Check Up
Sigma Family - HPB Cleaning Cover Image
Sigma HPB Cleaning
Screenshot 2022-04-12 at 15.57.01
Recommended Parts

Downloads

Use this section to download any updates, software or media to get the most out of your machine. 

Westomatic Vending Services Sigma Touch GraphicTemplates
Sigma Touch Graphic Template
Westomatic Vending Services Sigma Touch Advertising Screen
Sigma Touch Advertising Videos
Westomatic Vending Services Sigma Touch Branding Pack
Sigma Touch Branding Pack
Westomatic Vending Services Sigma Touch Software
Sigma Touch Software

Tutorials

Use this section to view user guides and tutorials to keep your Sigma Touch Coffee machine in tip-top condition.

HPB Overview
Fitting Sigma Brewer Service Kit HPB
LPB Overview
Fitting Sigma Brewer Service Kit LPB
Correct Cup Loading
Calibrate the cup sensor
Cleaning the Screen
Mixer Motor Seals
Adjust Grind Courseness
Replace Grinder blades
Change the filter belt

LIVE TECHNICAL FEED

Touch Screen Issue
A number of faults have been reported about the touch sensitivity of the screen. After thorough testing we have found this to be due to the fact that when the screen is being cleaned they are spraying the cleaning solution directly onto the screen, which causes liquid to drip down inside the machine and in turn effects the functionality.
PLEASE ONLY CLEAN THE SCREEN BY SPRAYING THE SOLUTION ON THE CLOTH.
See Question 1 of the ‘How do I?’ section below for more info.

HOW DO I...

Clean the screen?

You will need:

Screen Cleaner – 1015014
Microfibre Cloth – 1015012

  1. Unplug the Molex Connector
  2. Undo the 6 x 7mm Nuts
  3. Lift off the Screen
  4. Spray Screen Cleaner onto the Micro Fibre Cloth (Do not spray directly onto the screen)
  5. Clean the screen

       

        6. Replace the screen

         7. Redo the 6 x 7mm nuts

         (DO NOT OVER TIGHTEN)

         8. Reconnect the Molex connector

Calibrate the cup sensor?

1. Clean sensor lense

2. Check to see if GREEN LED is on

3. Turn Screw clockwise till AMBER LED is on

4. Turn anti-clockwise 1/4 back

5. Test cup dropper in ‘operator functions’ to check calibration

Test & load the cup dropper?

1. Open the door

2. ‘Operator Functions’

3. Test Cup Dropper

4. Cup carousel will time out after 30 seconds

DOCUMENT – HOW TO LOAD THE CUP UNIT

Add custom branding to the screen?

To add custom branding to the screen you will need to use the Sigma Touch Custom Branding Pack which can be downloaded HERE

Diagnose an error code?

To diagnose and error code please refer to our Quick Reference Guide which you can download HERE

Sigma FAQs

Machine shows error 14-7

14 Simply means a circuit error. The number following is the actual error. In this case ‘7’ means Faulty Valve 2. 

Refer to Triac circuit information

Reason: 

Faulty Valve 2 

 

Solution:

Replace Valve and re-calibrate 6fl oz or 170 grams

Test:

Test valve 2 in flush mode

Machine has lost configuration

Solution:

Reload CONFIG file

  • Service Mode
  • Machine Settings
  • Load/Read/Config
  • Load into machine
  • or Read from machine

Refer to Service menu image

Test:

Test All Drink Selections

Machine shows error code 14-20

14 Simply means a circuit error. The number following is the actual error. In this case ’20’ means Whipper Station 1 issue. 

Refer to Triac circuit information

Reason: 

Whipper Station 1 Issue

Possible Cause/Solution: 

Cause 1 : 

Whipper Seals leaking

Solution 1 :

Check all seals – replace whipper seals if needed 

Cause 2 : 

Fuse F11 

Solution 2 :

Check Fuse F11 – replace if needed (Part #)

Cause 3 : 

Whipper Motor Issue

Solution 3 :

Check Check Whipper Motor – replace if needed 

Cups not indexing

Preliminary Check: 

Check that ‘Carousel Time out’ is set to 30 seconds. 

  • Machine settings
  • Cup settings
  • Carousel timeout/30 seconds

Possible Cause/Solution: 

Cause 1 : 

Cups are jammed/loaded incorrectly/damaged

Solution 1 : 

Reload cups – Refer to HOW TO LOAD THE CUP UNIT

Cause 2 : 

Fuse F9 Issue

Solution 2 : 

Check F9 T2.0 Amp fuse and replace if needed 

  • Power off machine
  • Remove all cups
  • Check F9 Fuse
  • Power on machine

Cause 3 : 

Cup Carousel Motor Issue

Solution 3 : 

Does Cup carousel turn under load?

Yes – HOW TO LOAD THE CUP UNIT

No – Replace cup carousel Motor 

Test : 

Cups not dropping

Possible Cause/Solution: 

Cause 1 : 

Cups are jammed/loaded incorrectly/damaged

Solution 1 : 

Reload cups – Refer to HOW TO LOAD THE CUP UNIT

Cause 2 : 

Fuse F9 Issue

Solution 2 : 

Check F9 T2.0 Amp fuse and replace if needed 

  • Power off machine
  • Remove all cups
  • Check F9 Fuse
  • Power on machine

Cause 3 : 

Operation of Cup Scrolls

Solution 3 : 

Reload a few cups – NOT into one position

Test : 

Featured Tutorial

FITTING A BREWER SERVICE KIT

Brewer Service Kits are compatible across our entire Sigma range

For full instructions on how to fit a brewer service kit please use the link below.

Subscribe to our Video Tutorials

Video tutorials can be found on our YouTube Channel. Subscribe Now

Relevant Technical Bulletins

LOOKING FOR PARTS